目录
- 引言
- 一、离散化概念
- 二、离散化模板
- 三、例题
- 四、测试
引言
这个离散化我的理解就是你如果要用到数组的下标进行存数,会有多个询问针对下标进行操作,然后这个下标特别的大,而且存的数也是特别的分散,举个例子就是有三个数,1,2,3,它们对应的下标分别为1,10000,1e9,所以如果开那么大的数组肯定浪费了,而且可能会爆内存,然后就需要离散化了,那么进入正题吧!
一、离散化概念
引入离散化的背景已经在引言里说过了,离散化就是把要用到的所有的下标,从1开始按顺序排好,然后存到数组中,也就是给原来的下标填了一层映射关系,之后所有要用到下标的地方都通过映射找到其对应的下标,这就是离散化了,然后注意的一点就是离散化后的下标是从1开始的。
二、离散化模板
vector<int> alls; //存的所有要用到的下标
sort(alls.begin(),alls.end()); //按下标的大小排序
alls.erase(unique(alls.begin(),alls.end()), alls.end()); //去重int find(int x) //找到原来下标x的值在alls里的下标
{int l = 0, r = alls.size() - 1;while(l < r){int mid = l + r >> 1;if(alls[mid] >= x) r = mid;else l = mid + 1;}return r + 1;
}
三、例题
假定有一个无限长的数轴,数轴上每个坐标上的数都是 0。现在,我们首先进行 n 次操作,每次操作将某一位置 x 上的数加 c。
接下来,进行 m 次询问,每个询问包含两个整数 l 和 r,你需要求出在区间 [l,r] 之间的所有数的和。输入格式
第一行包含两个整数 n 和 m。接下来 n 行,每行包含两个整数 x 和 c。再接下来 m行,每行包含两个整数 l 和 r输出格式
共 m 行,每行输出一个询问中所求的区间内数字和。数据范围−109≤x≤109,1≤n,m≤105,−109≤l≤r≤109,−10000≤c≤10000输入样例:
3 3
1 2
3 6
7 5
1 3
4 6
7 8输出样例:
8
0
5
#include <iostream>
#include <vector>
#include <algorithm>using namespace std;typedef pair<int,int> PII;
#define x first
#define y secondconst int N = 3e5+10;int n, m;
int a[N], s[N];
vector<int> alls;
vector<PII> adds, query;int find(int x)
{int l = 0, r = alls.size() - 1;while(l < r){int mid = l + r >> 1;if(alls[mid] >= x) r = mid;else l = mid + 1;}return r + 1;
}int main()
{cin >> n >> m;for(int i = 0; i < n; ++i){int x, c;cin >> x >> c;alls.push_back(x);adds.push_back({x,c});}for(int i = 0; i < m; ++i){int l, r;cin >> l >> r;alls.push_back(l);alls.push_back(r);query.push_back({l,r});}sort(alls.begin(), alls.end());alls.erase(unique(alls.begin(),alls.end()), alls.end());for(auto item: adds){int x = find(item.x);a[x] += item.y;}for(int i = 1; i <= alls.size(); ++i) s[i] = s[i-1] + a[i];for(auto item: query){int l = find(item.x), r = find(item.y);cout << s[r] - s[l-1] << endl;}return 0;
}
四、测试
可以看出是通过了的,然后也AC了