组网需求
如图1所示,SwitchA、SwitchB和SwitchC之间运行OSPF,SwitchA和SwitchB之间的交换仅作透传功能。现在需要SwitchA和SwitchB能快速感应它们之间的链路状态,当链路SwitchA-SwitchB发生故障时,业务能快速切换到备份链路SwitchA-SwitchC-SwitchB上
配置思路
采用如下思路配置OSPF与BFD联动:
- 在各交换机上配置OSPF基本功能,实现整个OSPF网络的互通。
- 在各交换机上配置OSPF与BFD联动功能,实现当SwitchA和SwitchB之间出现链路故障时快速的切换到备份链路。
操作步骤
1.配置各接口所属的VLAN
配置SwitchA。SwitchB和SwitchC的配置与SwitchA类似
<Huawei>system-view //进入系统视图
[SW_a]undo info-center enable //关闭信息提示
[SW_a]sysname SW_A //修改设备名
[SW_A]vlan batch 10 30 //创建vlan10 30
[SW_A]int GigabitEthernet 0/0/1 //进入接口
[SW_A-GigabitEthernet0/0/1]port link-type trunk //配置干道模式
[SW_A-GigabitEthernet0/0/1]port trunk allow-pass vlan 10 //放行vlan10
[SW_A-GigabitEthernet0/0/1]quit //退出配置
[SW_A]int GigabitEthernet 0/0/2 //进入接口
[SW_A-GigabitEthernet0/0/2]port link-type trunk //配置干道模式
[SW_A-GigabitEthernet0/0/2]port trunk allow-pass vlan 30 //放行vlan30
[SW_A-GigabitEthernet0/0/2]quit //退出配置
[SW_A]
2.配置VLANIF接口的IP地址
# 配置SwitchA。SwitchB和SwitchC的配置与SwitchA类似
[SW_A]interface Vlanif 10 //进入vlan10
[SW_A-Vlanif10]ip address 10.1.1.1 24 //配置IP地址
[SW_A-Vlanif10]quit //退出配置
[SW_A]interface Vlanif 30 //进入vlan30
[SW_A-Vlanif30]ip address 10.3.3.1 24 //配置IP地址
[SW_A-Vlanif30]quit //退出配置
[SW_A]
3.配置OSPF基本功能
#配置SW_A
[SW_A]ospf 1 router-id 10.10.10.1 //配置router-id
[SW_A-ospf-1]area 0 //进入area0
[SW_A-ospf-1-area-0.0.0.0]network 10.1.1.0 0.0.0.255 //宣告1.0网段
[SW_A-ospf-1-area-0.0.0.0]network 10.3.3.0 0.0.0.255 //宣告3.0网段
[SW_A-ospf-1-area-0.0.0.0]quit //退出配置
[SW_A-ospf-1]quit //退出ospf
[SW_A]
#配置SW_B
[SW_B]ospf 1 router-id 10.10.10.2
[SW_B-ospf-1]area 0
[SW_B-ospf-1-area-0.0.0.0]network 10.2.2.0 0.0.0.255
[SW_B-ospf-1-area-0.0.0.0]network 10.3.3.0 0.0.0.255
[SW_B-ospf-1-area-0.0.0.0]network 172.16.1.0 0.0.0.255
[SW_B-ospf-1-area-0.0.0.0]quit
[SW_B-ospf-1]quit
[SW_B]
#配置SW_C
[SW_C]ospf 1 router-id 10.10.10.3
[SW_C-ospf-1]area 0
[SW_C-ospf-1-area-0.0.0.0]network 10.1.1.0 0.0.0.255
[SW_C-ospf-1-area-0.0.0.0]network 10.2.2.0 0.0.0.255
[SW_C-ospf-1-area-0.0.0.0]quit
[SW_C-ospf-1]quit
[SW_C]
# 配置完成后,执行命令display ospf peer,可以看到SwitchA,SwitchB和SwitchC之间互相建立了邻接关系。以SwitchA的显示结果为例。
[SW_A]display ospf peer OSPF Process 1 with Router ID 10.10.10.1Neighbors Area 0.0.0.0 interface 10.1.1.1(Vlanif10)'s neighborsRouter ID: 10.10.10.3 Address: 10.1.1.2 State: Full Mode:Nbr is Master Priority: 1DR: 10.1.1.1 BDR: 10.1.1.2 MTU: 0 Dead timer due in 34 sec Retrans timer interval: 5 Neighbor is up for 00:01:32 Authentication Sequence: [ 0 ] [SW_A]
# 查看SwitchA的OSPF路由表的信息,可以看到去往SwitchB和SwitchC的路由表项。而去往目的网段172.16.1.0/24的路由下一跳地址为10.3.3.2,说明流量在链路SwitchA→SwitchB上传输
[SW_C]display ospf routing OSPF Process 1 with Router ID 10.10.10.3Routing Tables Routing for Network Destination Cost Type NextHop AdvRouter Area10.1.1.0/24 1 Stub 10.1.1.3 10.10.10.3 0.0.0.010.2.2.0/24 1 Transit 10.2.2.3 10.10.10.3 0.0.0.010.3.3.0/24 2 Stub 10.2.2.2 10.10.10.2 0.0.0.0172.16.1.0/24 2 Stub 10.2.2.2 10.10.10.2 0.0.0.0Total Nets: 4 Intra Area: 4 Inter Area: 0 ASE: 0 NSSA: 0 [SW_C]
4.配置OSPF与BFD联动
#在SW_A上配置OSPF与BFD联动功能
[SW_A]bfd
[SW_A-bfd]quit
[SW_A]ospf 1
[SW_A-ospf-1]bfd all-interfaces enable
[SW_A-ospf-1]quit
[SW_A]
#在SW_B上配置OSPF与BFD联动功能
[SW_B]bfd
[SW_B-bfd]quit
[SW_B]ospf 1
[SW_B-ospf-1]bfd all-interfaces enable
[SW_B-ospf-1]q
[SW_B]
#在SW_C上配置OSPF与BFD联动功能
[SW_C]bfd
[SW_C-bfd]quit
[SW_C]ospf 1
[SW_C-ospf-1]bfd all-interfaces enable
[SW_C-ospf-1]quit
[SW_C]
# 配置完成后,在SwitchA或SwitchB、SwitchC上执行display ospf bfd session all命令,可以看到BFD会话的状态为Up。以SwitchA的显示为例。
[SW_C]display ospf bfd session all OSPF Process 1 with Router ID 10.10.10.3Area 0.0.0.0 interface 10.1.1.3(Vlanif10)'s BFD SessionsNeighborId:10.10.10.1 AreaId:0.0.0.0 Interface:Vlanif10 BFDState:up rx :1000 tx :1000 Multiplier:3 BFD Local Dis:8194 LocalIpAdd:10.1.1.3RemoteIpAdd:10.1.1.1 Diagnostic Info:No diagnostic informationArea 0.0.0.0 interface 10.2.2.3(Vlanif20)'s BFD SessionsNeighborId:10.10.10.2 AreaId:0.0.0.0 Interface:Vlanif20 BFDState:up rx :1000 tx :1000 Multiplier:3 BFD Local Dis:8193 LocalIpAdd:10.2.2.3RemoteIpAdd:10.2.2.2 Diagnostic Info:No diagnostic information[SW_C]
配置结果
# 对SW_C的GE0/0/1接口执行shutdown命令,模拟链路故障。
[SW_C]int GigabitEthernet 0/0/1
[SW_C-GigabitEthernet0/0/1]shutdown
[SW_C-GigabitEthernet0/0/1]quit
[SW_C]
# 在SwitchA上查看OSPF路由表
[SW_A]display ospf bfd session all OSPF Process 1 with Router ID 10.10.10.1Area 0.0.0.0 interface 10.3.3.1(Vlanif30)'s BFD SessionsNeighborId:10.10.10.2 AreaId:0.0.0.0 Interface:Vlanif30 BFDState:up rx :1000 tx :1000 Multiplier:3 BFD Local Dis:8195 LocalIpAdd:10.3.3.1RemoteIpAdd:10.3.3.2 Diagnostic Info:No diagnostic information[SW_A]
111